Alerta de seguridad

Alerta de Seguridad

Dos plugin para WordPress, InfiniteWP Client y WP Time Capsule, contienen una seria vulnerabilidad que ha expuesto aproximadamente unos 320.000 sitios.

Este par de plugins, se usan para administrar varios sitios con WordPress desde un único servidor y crear copias de seguridad de archivos y bases de datos cuando aparecen actualizaciones.

El problema

Los dos han sido examinados por la empresa de ciber seguridad WebArx y, en su informe, dicen haber encontrado «problemas lógicos en el código que le permite iniciar sesión en una cuenta de administrador sin contraseña».

InfiniteWP está activo en más de 300,00 sitios, mientras que WP Time Capsule está activo en al menos 20,000 dominios, según la librería de WordPress.

Según las declaraciones hechas el pasado martes, el impacto en WP Time Capsule se produce en las versiones anteriores a la 1.9.4.5, en donde es posible usar un requerimiento POST con un componente JSON codificado en Base64, para saltarse los requerimientos de seguridad y acceder sabiendo sólo el nombre de un usuario administrador.

En el caso de WP Time Capsule, las versiones afectadas son los anteriores a la 1.21.16, en las que una línea de una función permite que se cree una cadena de caracteres en un requerimiento POST que llama a otra función que obtiene todas las cuentas de administración y accede con las credenciales del primer administrador de la lista.

La compañía WebArx ha informado sobre las vulnerabilidades en el desarrollo de estos plugin el pasado 7 de enero. Ambos autores de los plugin han reaccionado rápido y han lanzado actualizaciones parcheadas durante las siguientes 24 horas.

Así mismo, los desarrolladores dicen haber editado medidas de seguridad adicionales para evitar las peticiones POST maliciosas.

Recomendamos encarecidamente a nuestros lectores que usan esas herramientas, que actualicen lo antes posible los plugin correspondientes.

La empresa de seguridad, en su comunicado advierte: «Es difícil bloquear esta vulnerabilidad con las reglas generales del firewall porque la carga útil está codificada y una carga maliciosa no se vería muy diferente en comparación con una carga útil de aspecto legítimo de ambos complementos.»

Por su parte, sobre los desarrolladores han manifestado: «Siempre es bueno ver a los desarrolladores que están tomando medidas rápidamente y están informando a sus clientes sobre los problemas para ayudar a las personas a actualizar a una versión más segura lo antes posible.»


Canales de Telegram: Canal SoloWordpressCanal SoloLinux 


¡Espero que este articulo te sea de utilidad, puedes ayudarnos a mantener el servidor con una donación en PayPal, o también colaborar con el simple gesto de compartir nuestros artículos en tu sitio web, blog, foro o redes sociales!

¡Tus comentarios y preguntas nos ayudan a mejorar, por favor comenta!

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Esta web utiliza cookies, puedes ver aquí la Política de Cookies